Lek in McAfee Agent laat aanvaller code met systeemrechten uitvoeren

Een kwetsbaarheid in de Agent-software van antivirusbedrijf McAfee maakt het mogelijk voor een aanvaller die al toegang tot een computer heeft om code met systeemrechten uit te voeren en zo volledige controle over de machine te krijgen. De McAfee Agent is geen beveiligingssoftware op zichzelf, maar communiceert tussen de beveiligingssoftware op het systeem en de McAfee ePO-server. De agent wordt met verschillende McAfee producten meegeleverd, waaronder Endpoint Security.

De Agent-software maakt gebruik van een OpenSSL-onderdeel dat weer naar een directory wijst waar gebruikers zonder rechten controle over hebben. De McAfee Agent draait met systeemrechten. Door een speciaal geprepareerd openssl.cnf-bestand in deze directory te plaatsen kan een ongeprivilegieerde gebruiker code met systeemrechten uitvoeren. Het beveiligingslek, aangeduid als CVE-2022-0166, heeft een impactscore van 7,8 en werd gevonden door Will Dormann van het CERT Coordination Center (CERT/CC) van de Carnegie Mellon Universiteit. McAfee heeft het probleem verholpen in versie 5.7.5 van de Agent-software.

Bron: Security.nl

Geef een reactie

Het e-mailadres wordt niet gepubliceerd. Vereiste velden zijn gemarkeerd met *

12Privacy.nl